Como eu instalo o Adobe Acrobat Reader do repository?

Como instalo o Adobe Acrobat Reader no Ubuntu 14.04 usando um repository Trusty apt ?

Esta não é uma duplicata de Como instalar o pacote do Adobe Acrobat Reader baixado do site da Adobe? . Em Synaptic > Repositories > Other software eu habilitei “Canonical Partners”, mas ainda não consigo instalar o acroread pois ele não está disponível no meu sistema de 64 bits.

Aqui está a saída do console:

 root@liv-inspiron:/home/liv# apt-get install acroread Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package acroread root@liv-inspiron:/home/liv# apt-get install acroread:i386 Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package acroread 

É um pouco mais manual instalar o Adobe Acrobat Reader no Ubuntu 14.04, mas não é difícil.

Abra um terminal.

Tipo:

 cd ~/Downloads && wget -c http://ardownload.adobe.com/pub/adobe/reader/unix/9.x/9.5.5/enu/AdbeRdr9.5.5-1_i386linux_enu.deb 

Isso baixa o arquivo DEB da Adobe e o coloca na pasta Downloads. Próximo tipo:

 sudo dpkg -i AdbeRdr9.5.5-1_i386linux_enu.deb 

Isso instalará o Adobe Acrobat Reader.

Se você estiver em uma máquina de 64 bits, talvez seja necessário adicionar as bibliotecas ausentes que Nim mencionou:

 sudo apt-get install libgtk2.0-0:i386 libnss3-1d:i386 libnspr4-0d:i386 lib32nss-mdns libxml2:i386 libxslt1.1:i386 libstdc++6:i386 

Se você quiser o Acrobat Reader como seu aplicativo padrão para PDFs, digite:

 mimeopen -d *.pdf 

Ele irá exibir uma lista de programas (exibido 3 para mim). Selecione o número que possui o Acrobat Reader. Ele abrirá o Acrobat Reader e informará que não é possível abrir ‘* .pdf’. Ignore esse erro e feche o Adobe Reader. Você deveria estar definido agora.

Em vez de listar todas as dependencies explicitamente, você poderia fazer isso:

 sudo apt-get install -f 

Isso consertará todas as dependencies não resolvidas automaticamente.

Então toda a sequência de comandos tem que ser assim:

 cd ~/Downloads && wget -c http://ardownload.adobe.com/pub/adobe/reader/unix/9.x/9.5.5/enu/AdbeRdr9.5.5-1_i386linux_enu.deb sudo dpkg -i AdbeRdr9.5.5-1_i386linux_enu.deb sudo apt-get install -f 

Você pode ver no link: ubuntu-updates (veja a coluna de lançamento) que o pacote acroread não está liberado para o 14.04 (trusty) ainda.

Portanto, espere até que seja adicionado aos repositorys de parceiros da Canonical. Caso contrário, você pode instalar a versão antiga. Veja uma pergunta semelhante : pergunta semelhante para awn.

Nesse caso, recebo o mesmo erro por awn: E: Unable to locate package avant-window-navigator

  1. Faça o download do Adobe Reader em: https://get.adobe.com/reader/otherversions/ .

Selecione o sistema: Linux, seu idioma, o Reader 9.5.5 para Linux (.deb)

  1. Instalar o gdebi:
 sudo apt-get install gdebi 
  1. Instale o Adobe Reader via gdebi e aceite as dependencies:
 sudo gdebi PACKAGENAME.deb 
  1. Instale as bibliotecas necessárias:
 sudo apt-get install libgtk2.0-0:i386 libnss3-1d:i386 libnspr4-0d:i386 lib32nss-mdns libxml2:i386 libxslt1.1:i386 libstdc++6:i386 

Por fim, inicie o Adobe Reader no menu de contexto dos menus, painéis ou arquivos PDF.

via: ubuntuhandbook.org

a partir de 2014-10-23 a resposta ainda é “você não” (ou não pode)

É improvável que isso aconteça também.

a última versão do Acrobat reader para unix / linux é 9.5.5

Isso funcionou para mim (a resposta do undespairable em 17 de agosto não conseguiu instalar alguns pacotes necessários) no Xubuntu 14.04

 # as root (prefix with sudo if you are running as an unprivileged user) apt-get install libgtk2.0-0:i386 libnss3-1d:i386 libnspr4-0d:i386 lib32nss-mdns libxml2:i386 libxslt1.1:i386 libstdc++6:i386 apt-get install --reinstall gtk2-engines-murrine:i386 gtk2-engines-pixbuf:i386 cd /tmp && wget -c http://ardownload.adobe.com/pub/adobe/reader/unix/9.x/9.5.5/enu/AdbeRdr9.5.5-1_i386linux_enu.deb dpkg -i AdbeRdr9.5.5-1_i386linux_enu.deb 

após o teste:

 rm -rf /tmp/acroread_1000_1000 rm /tmp/AdbeRdr9.5.5-1_i386linux_enu.deb 

Tente usar o terminal:

 sudo apt-get install acroread 

e se não estiver funcionando – use:

 sudo apt-get install acroread:i386 

Edit: Primeiro use os seguintes comandos:

 sudo apt-add-repository multiverse sudo apt-get update 

Hoje eu testei o seguinte com sucesso em uma nova instalação do kUbuntu 14.04.4 (um sabor oficial do Ubuntu).

Adicionar PPA canônico

 sudo add-apt-repository "deb http://archive.canonical.com/ precise partner" 

Atualizar e Instalar

 sudo aptitude update sudo aptitude install acroread 

Funciona no kUbuntu 14.04 LTS
A partir de 30 de abril de 2016, o Doesnt funciona no novo kUbuntu 16.04 LTS

Como eu finalmente instalei o Acrobat Reader no Ubuntu 14.04 em uma máquina de 64 bits:

  1. Eu baixei a versão .deb do adobe.com;

  2. Instale o pacote usando gedbi ;

  3. Instale as bibliotecas:

     sudo apt-get install libgtk2.0-0:i386 libnss3-1d:i386 libnspr4-0d:i386 lib32nss-mdns libxml2:i386 libxslt1.1:i386 libstdc++6:i386 

Feito!

Intereting Posts